cannot work with jquery1.9.1 and 1.10.2

Jul 22, 2013 at 8:01 AM
I make some web system with jHtmlArea.

The page with jquery-1.8.3.min.js works well.
But with jquery-1.9.1, jquery-1.10.2, cannot work well.

What should I do?
If I should change something to jquery-1.9.1 or jquery-1.10.2,
please tell me.
Jul 29, 2013 at 11:33 AM
Edited Jul 29, 2013 at 11:38 AM
I had the solution by myself.

That is the addition of jquery migrate like follows.
<script type="text/javascript" src="http://code.jquery.com/jquery-1.10.2.min.js"></script>
<script type="text/javascript" src="http://code.jquery.com/jquery-migrate-1.2.1.min.js"></script>
ref) jquery migrate
Aug 13, 2013 at 6:34 PM
jHtmlArea breaks with jQuery 1.9+ because $.browser has been removed. Use of $.browser is frowned upon. jQuery recommends using the Modernizr library to detect specific features instead, but this does not seem straightforward to apply in this case. Using jquery-migrate, as noznoz7 suggested, will work, but this does not seem like the best solution...
Sep 10, 2013 at 9:57 AM
Hello,
Version 0.8 will solve these problems. It is found under the "Source code" - https://jhtmlarea.codeplex.com/SourceControl/latest
Sep 10, 2013 at 6:25 PM
Thanks Steffan! I found the verson 0.8 code under the jHtmlArea Website directory. I think your solution to include a $.browser in the script is reasonable.
Sep 15, 2013 at 10:06 AM
Thanks Steffan.
I've confirmed new version without jquery-migrate.